Tuesday, October 8, 2013

OSPF Case Study

Objectives
• Plan, design, and implement the International Travel Agency network shown in the diagram and described below.
• Verify that all configurations are operational and functioning according to the guidelines.

1. Use the addressing scheme shown in the diagram.
2. Configure OSPF with the networks shown in the diagram.
3. Configure the OSPF backbone area to be on Loopback0 on HQ.
4. Configure the Frame Relay subnets as point-to-point subinterfaces, with the link between HQ and East in area 100, and the link between HQ and West in area 300.
5. Configure area 300 as an NSSA.
6. Configure the router East loopback interfaces to be in area 200. Summarize this area with the most efficient summary.
7. Redistribute the loopback network on router West into OSPF.
8. Create virtual links as necessary for full connectivity.
9. Make sure that all loopback interfaces are advertised with the correct subnet mask.

Tcl Script Verification
R1# tclsh
foreach address {
10.1.1.9
10.1.1.13
10.1.1.101
10.1.1.105
10.1.1.109
10.1.1.113
10.1.1.1
10.1.1.2
10.1.1.5
10.1.1.6
} {
ping $address }
Verified when completes lab
R1(tcl)#foreach address {
+>(tcl)#10.1.1.9
+>(tcl)#10.1.1.13
+>(tcl)#10.1.1.101
+>(tcl)#10.1.1.105
+>(tcl)#10.1.1.109
+>(tcl)#10.1.1.113
+>(tcl)#10.1.1.1
+>(tcl)#10.1.1.2
+>(tcl)#10.1.1.5
+>(tcl)#10.1.1.6
+>(tcl)#} {
+>(tcl)#ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/20/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.101, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/22/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.105, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/13/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.109, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/12/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.113, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/72 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/22/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/17/84 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/14/28 ms
R1(tcl)#exit

====================================================
Device Configuration ::::::
R1#sh running-config
Building configuration...

Current configuration : 1488 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!no ip domain lookup
ip domain name lab.local
!        
interface Loopback1
 ip address 10.1.1.9 255.255.255.252
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
!        
interface Serial0/0.102 point-to-point
 ip address 10.1.1.1 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 102  
!
interface Serial0/0.103 point-to-point
 ip address 10.1.1.5 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 103  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 100 virtual-link 10.1.1.113
 area 300 nssa
 network 10.1.1.0 0.0.0.3 area 100
 network 10.1.1.4 0.0.0.3 area 300
 network 10.1.1.8 0.0.0.3 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
========================================================

R2#sh running-config
Building configuration...

Current configuration : 1746 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback101
 ip address 10.1.1.101 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback105
 ip address 10.1.1.105 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback109
 ip address 10.1.1.109 255.255.255.252
 ip ospf network point-to-point
!        
interface Loopback113
 ip address 10.1.1.113 255.255.255.252
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
!
interface Serial0/0.201 point-to-point
 ip address 10.1.1.2 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 201  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 100 virtual-link 10.1.1.9
 area 200 range 10.1.1.96 255.255.255.224
 network 10.1.1.0 0.0.0.3 area 100
 network 10.1.1.100 0.0.0.3 area 200
 network 10.1.1.104 0.0.0.3 area 200
 network 10.1.1.108 0.0.0.3 area 200
 network 10.1.1.112 0.0.0.3 area 200
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!        
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end
======================================================
R4#sh running-config
Building configuration...

Current configuration : 1380 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback3
 ip address 10.1.1.13 255.255.255.252
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.301 point-to-point
 ip address 10.1.1.6 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 301  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!        
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 300 nssa
 redistribute connected subnets
 network 10.1.1.4 0.0.0.3 area 300
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

=======================================================
FRS#sh running-config
Building configuration...

Current configuration : 1404 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
no ip domain lookup
ip domain name lab.local
!        
frame-relay switching
!          
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
 frame-relay route 103 interface Serial0/2 301
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

=======================================================

1 comment:

  1. Grand Victoria Casino, Las Vegas - Mapyro
    Get directions, reviews and information for 광양 출장안마 Grand Victoria Casino in Las Vegas, NV. Grand Victoria 오산 출장마사지 Casino 동두천 출장마사지 is located in downtown Las Vegas and near The Mirage. Rating: 2.1 · 경상남도 출장마사지 ‎1,821 reviews 서산 출장샵

    ReplyDelete