Monday, October 28, 2013

Redistribution Between RIP and OSPF


Objectives


• Review configuration and verification of RIP and OSPF.
• Configure passive interfaces in both RIP and OSPF.
• Filter routing updates using distribute lists.
• Redistribute static routes into RIP.
• Redistribute RIP routes into OSPF.
• Redistribute OSPF routes into RIP.
• Originate a default route into OSPF.
• Set a default seed metric.
• Modify OSPF external network types.
• Configure summary addresses.


Step 1: Configure loopbacks and assign addresses.

 

Step 2: Configure RIPv2.


Configuring RIPv2 on a router is fairly simple:
• Type the global configuration command router rip to enter RIP configuration mode.
• Enable RIPv2 with the version 2 command.
• Enter the no auto-summary command to disable automatic summarization at classful network boundaries.
• Add the networks you want using the network network command.

Q : Based on the topology diagram, which major networks need to be advertised into RIP for R1?

Ans : 
 
172.16.0.0/16
192.168.48.0/24
192.168.49.0/24
192.168.50.0/24
192.168.51.0/24
192.168.70.0/24

Q : Which major networks need to be advertised into RIP for R2?

Ans : Only 172.16.0.0/16


Step 3: Configure passive interfaces in RIP.

Q : What are some reasons to prevent RIP from sending updates out a particular interface?

Ans : RIPv2 does not use an adjacency system. Therefore, RIPv2 floods all of its routing updates out of its interfaces rather than developing adjacencies with short hello packets like EIGRP and OSPF. Because RIPv2 could flood packets out interfaces where there are no RIPv2 receivers, it is a best practice to prevent RIP packets from being sent out these interfaces.

 Q : Does RIPv2 send advertisements out loopback interfaces?

 Ans : By default, loopback interfaces act like normal interfaces in RIPv2 when sending and receiving packets. However, a router will never have RIPv2 neighbors out its loopback interface, so loopback interfaces can always be configured as passive interfaces, thereby saving CPU resources.

 

Step 4: Summarize a supernet with RIP. 

Q : Which RIP routes should you summarize because they are contiguous and which mask should you use?

Ans : Summarize 192.168.48.0/24 through 192.168.51.0/24. Use a 22-bit mask to create the supernet.

 

Q : Will this route to Null0 affect routing to prefixes with longer addresses on R1? Explain.

Ans : The routing table first matches based on longest IP prefix. If any of the summarized networks are routable on R1, as in this situation, R1 uses the connected route with the longer mask to reach those networks. If one of those interfaces were to be shut down, R1 would send traffic for that network to its Null0 virtual interface.

Step 5: Suppress routes using prefix lists.

Q : Why would you want to filter updates being sent out or coming in?

Ans : The intention is to summarize addresses at R1, achieving benefits such as smaller routing tables and the prevention of route flapping disturbing network stability. By redistributing the static route into RIPv2, only the summary route was added, but the more specific routes were not filtered. To achieve these benefits, filter the outgoing routes to R2 by allowing all routes except the 24-bit routes.

Step 6: Configure OSPF.

Q : You can verify this by viewing the output of the show ip route command on R2. Do you see a 192.168.0.0/16 supernet?

Ans :   No, because the network command selects interfaces by IP address. It does not set the exact prefix to be advertised.

 

Step 7: Configure passive interfaces in OSPF.

Q : How is this different from the RIP version of this command?

Ans : Passive interfaces in RIPv2 prevent outgoing routing information via multicast.
Because OSPF must create an adjacency before sending routing updates, the OSPF version of the passive-interface command prevents sending or processing OSPF packets and, therefore, prevents adjacencies.

Step 8: Allow one-way redistribution.

Step 9: Redistribute between two routing protocols.

Step 10: Set a default seed metric.

Step 11: Change the OSPF external network type.


Q : Where would an external type 1 metric be useful?

Ans : If there are multiple paths through an OSPF domain to an external destination network, use E1 routes so that OSPF will evaluate the shortest cost path. Especially use this option if multiple ASBRs are advertising the same destination network to prevent suboptimal routing.

Q : Where would an external type 2 metric be useful?

Ans : If there is only one ASBR advertising an external route, use E2 routes. In this scenario, use the E1 type even though only one ASBR is advertising the external routes.

Q : Which attributes of the routes changed?

Ans : The external route type has been changed from E2 to E1. The metric, previously 10000, has been incremented to represent the path through the OSPF network to the ASBR.


__________________________________________________________________________________

 Final Device Configuration :

R1#sh running-config
Building configuration...

Current configuration : 1821 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!        
no ip domain lookup
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface Loopback48
 ip address 192.168.48.1 255.255.255.0
!
interface Loopback49
 ip address 192.168.49.1 255.255.255.0
!
interface Loopback50
 ip address 192.168.50.1 255.255.255.0
!
interface Loopback51
 ip address 192.168.51.1 255.255.255.0
!
interface Loopback70
 ip address 192.168.70.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.12.1 255.255.255.0
 clock rate 64000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router rip
 version 2
 redistribute static
 passive-interface default
 no passive-interface Serial0/0
 network 172.16.0.0
 network 192.168.48.0
 network 192.168.49.0
 network 192.168.50.0
 network 192.168.51.0
 network 192.168.70.0
 distribute-list prefix RIP-OUT out Serial0/0
 no auto-summary
!
ip classless
ip route 192.168.48.0 255.255.252.0 Null0
!
no ip http server
no ip http secure-server
!
ip prefix-list RIP-OUT seq 5 permit 192.168.48.0/22
ip prefix-list RIP-OUT seq 10 deny 192.168.48.0/22 le 24
ip prefix-list RIP-OUT seq 15 permit 0.0.0.0/0 le 32
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

____________________________________________________________________________

R2#show rUNning-config
Building configuration...

Current configuration : 1325 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!        
no ip domain lookup
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 bandwidth 64
 ip address 172.16.12.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 172.16.23.2 255.255.255.0
 clock rate 64000
!
router ospf 1
 log-adjacency-changes
 redistribute rip metric-type 1 subnets
 network 172.16.23.0 0.0.0.255 area 0
 default-information originate
 default-metric 10000
!
router rip
 version 2
 redistribute ospf 1 metric 4
 passive-interface Loopback0
 network 172.16.0.0
 no auto-summary
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!        
!
end

______________________________________________________________________

R3#sh running-config
Building configuration...

Current configuration : 1725 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!        
no ip domain lookup
!
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback20
 ip address 192.168.20.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback25
 ip address 192.168.25.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback30
 ip address 192.168.30.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback35
 ip address 192.168.35.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback40
 ip address 192.168.40.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 bandwidth 64
 ip address 172.16.23.3 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 passive-interface default
 no passive-interface Serial0/0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
 default-metric 10000
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end


====================================


 






Monday, October 21, 2013

Advanced Redistribution Lab







Objectives:


1. Configure EIGRP and OSPF for the network shown (use OSPF Area 0). Advertise all networks on all routers. Do not implement any summarization features for EIGRP or OSPF. Routes should never be advertised in both OSPF and EIGRP routing domains.

2. Enable full, mutual redistribution on R2 and R3 between OSPF and EIGRP. The 10.4.0.0/24 and 10.4.1.0/24 subnets should have a seed metric of 100 and an OSPF tag of 10 while the 10.4.2.0/24 and 10.4.3.0/24 subnets should have a seed metric of 200 and an OSPF tag of 20. All other subnets redistributed into OSPF should have a seed metric of 300 and an OSPF tag of 30. OSPF routes redistributed into EIGRP should have a seed metric of BW: 400 DLY: 20 REL: 255 LD: 1 MTU: 1500 and a tag of 40. Finally, external OSPF routes should not increment their metric as they pass through the OSPF domain.


3. Ensure the 10.4.4.0/24 network does not reach the OSPF routing domain.


4. Enable filtering using the assigned route tags to ensure redistributed routes do not cause any looping issues.


5. R3 has the preferred route to reach the 10.1.0.0/24 network. Ensure routers prefer this path over the path from R2.



Final Device Configuration :

R1#sh running-config
Building configuration...

Current configuration : 1164 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local
!   
interface Loopback0
 ip address 10.1.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 10.1.0.0 0.0.0.255 area 0
 network 10.1.12.0 0.0.0.255 area 0
 network 10.1.13.0 0.0.0.255 area 0
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
======================================================
R2#sh running-config
Building configuration...

Current configuration : 2031 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.23.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.24.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 route-map OSPF-TO-EIGRP
 network 10.1.23.0 0.0.0.255
 network 10.1.24.0 0.0.0.255
 distance eigrp 90 105
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map EIGRP-TO-OSPF
 network 10.1.12.0 0.0.0.255 area 0
!
ip classless
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
route-map EIGRP-TO-OSPF deny 5
 match tag 40
!
route-map EIGRP-TO-OSPF permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map EIGRP-TO-OSPF permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map EIGRP-TO-OSPF deny 30
 match ip address 3
!
route-map EIGRP-TO-OSPF permit 40
 set metric 300
 set tag 30
!
route-map OSPF-TO-EIGRP deny 5
 match tag 10 20 30
!
route-map OSPF-TO-EIGRP permit 10
 set metric 400 20 255 1 1500
 set tag 40
!
control-plane
!        
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
========================================================
R3#sh running-config
Building configuration...

Current configuration : 1834 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local
!       
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.13.3 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.23.3 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 route-map OSPF-TO-EIGRP
 network 10.1.23.0 0.0.0.255
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 subnets route-map EIGRP-TO-OSPF
 network 10.1.13.0 0.0.0.255 area 0
!
ip classless
!
no ip http server
no ip http secure-server
!
access-list 1 permit 10.4.0.0 0.0.0.255
access-list 1 permit 10.4.1.0 0.0.0.255
access-list 2 permit 10.4.2.0 0.0.0.255
access-list 2 permit 10.4.3.0 0.0.0.255
access-list 3 permit 10.4.4.0 0.0.0.255
route-map EIGRP-TO-OSPF deny 5
 match tag 40
!
route-map EIGRP-TO-OSPF permit 10
 match ip address 1
 set metric 100
 set tag 10
!
route-map EIGRP-TO-OSPF permit 20
 match ip address 2
 set metric 200
 set tag 20
!
route-map EIGRP-TO-OSPF deny 30
 match ip address 3
!
route-map EIGRP-TO-OSPF permit 40
 set metric 300
 set tag 30
!
route-map OSPF-TO-EIGRP deny 5
 match tag 10 20 30
!
route-map OSPF-TO-EIGRP permit 10
 set metric 400 20 255 1 1500
 set tag 40
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!        
!
end
=======================================================
R4#sh running-config
Building configuration...

Current configuration : 1257 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local
!        
interface Loopback0
 ip address 10.4.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.4.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.4.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.4.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.4.4.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.24.4 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
!
ip classless
!
no ip http server
no ip http secure-server
!        
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login   
!
!
end
=======================================================
with regards,
Zaw Min Htann

Thursday, October 17, 2013

Simple Redistribution

 

Objectives:


1. Configure EIGRP and OSPF for the network shown. Advertise all networks on all routers. Do not implement any summarization features for EIGRP or OSPF. Use Area 0 for the OSPF portion of the network and configure all Loopback interfaces on R3 as a point-to-point OSPF network.

2. Enable full redistribution between OSPF and EIGRP, implementing any necessary seed metrics to ensure all routers are able to see all routes. OSPF external routes should not increment their metric as they propagate the network.

3. Implement distribute-list filtering in such a way that the OSPF domain only sees odd numbered loopback networks coming from R1. Any even numbered subnet (including physical networks) should be hidden from OSPF.

4. Implement route-map filtering in such a way that the EIGRP domain does not see routes with a more specific subnet mask than /24.

Devices Configuration :


R1#sh running-config
Building configuration...

Current configuration : 1371 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local
!        
interface Loopback0
 ip address 10.1.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback4
 ip address 10.1.4.1 255.255.255.0
!
interface Loopback5
 ip address 10.1.5.1 255.255.255.0
!
interface Loopback6
 ip address 10.1.6.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router eigrp 100
 network 10.0.0.0
 no auto-summary
!        
ip classless
!
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

=========================================================================
R2#sh running-config
Building configuration...

Current configuration : 1466 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
!
!        
!
no ip domain lookup
ip domain name lab.local
!        
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.23.2 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 redistribute ospf 1 metric 100 100 100 100 100 route-map FILTER_OSPF_TO_EIGRP
 network 10.1.12.0 0.0.0.255
 no auto-summary
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 100 metric 100 subnets
 network 10.1.23.0 0.0.0.255 area 0
 distribute-list 1 out
!
ip classless
!
!
no ip http server
no ip http secure-server
!
ip prefix-list CISCO seq 5 permit 10.0.0.0/8 le 24
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.3.0 0.0.0.255
access-list 1 permit 10.1.5.0 0.0.0.255
route-map FILTER_OSPF_TO_EIGRP permit 10
 match ip address prefix-list CISCO
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!        
!
end
=========================================================================
R3#sh running-config
Building configuration...

Current configuration : 1629 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!       
no ip domain lookup
ip domain name lab.local
!        
interface Loopback0
 ip address 10.1.7.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback1
 ip address 10.1.8.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback2
 ip address 10.1.9.1 255.255.255.0
 ip ospf network point-to-point
!        
interface Loopback3
 ip address 10.1.10.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback4
 ip address 10.1.11.1 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback5
 ip address 10.1.11.5 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback6
 ip address 10.1.11.9 255.255.255.252
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.23.3 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

Wednesday, October 16, 2013

OSPF Special Area




Objectives:


1. Configure basic OSPF for the network shown. Advertise all networks attached to each router into OSPF using the simplest method available. To inject external networks into the OSPF domain, redistribute the static routes on R1. These routes should be marked as type E1.


2. OSPF should never form neighbor relationships on any interface where other OSPF routers do not exist (as shown in the diagram).


3. All routers in Area 0 should use MD5 authentication for OSPF neighbors. Routers in Area 23 should be configured to support clear-text authentication for OSPF neighbors. All keys should be set to the passphrase ‘cisco’ (without quotes).


4. Routers in Area 45 are limited in their capacity and should not receive routes for networks outside the OSPF system. These routers should reach the external network using a default route which cannot be configured statically.


5. Routers in Area 23 must not receive any Type 3, 4, or 5 LSAs from the rest of the OSPF network. These routers should reach the external network using a default route with an initial OSPF cost of 100.


6. When this exercise is complete, all routers should be able to reach (ping) every route in the OSPF routing table


Device Configuration :

R1#sh running-config
Building configuration...

Current configuration : 1371 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local
!    
interface FastEthernet0/0
 ip address 10.100.1.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute static metric 50 metric-type 1 subnets
 passive-interface default
 no passive-interface FastEthernet0/0
 network 10.100.1.0 0.0.0.255 area 0
!
ip classless
ip route 172.31.0.0 255.255.255.0 Null0
ip route 172.31.1.0 255.255.255.0 Null0
ip route 172.31.2.0 255.255.255.0 Null0
ip route 172.31.3.0 255.255.255.0 Null0
!
!
no ip http server
no ip http secure-server
!
control-plane
!        
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
==================================================================================
R2#sh running-config
Building configuration...

Current configuration : 1589 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local

interface Loopback0
 ip address 172.30.0.1 255.255.255.0
!
interface Loopback1
 ip address 172.30.1.1 255.255.255.0
!
interface Loopback2
 ip address 172.30.2.1 255.255.255.0
!
interface Loopback3
 ip address 172.30.3.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.100.1.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.23.1.2 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 23 stub no-summary
 area 23 default-cost 100
 passive-interface FastEthernet0/1
 passive-interface Serial0/1
 network 10.23.1.0 0.0.0.255 area 23
 network 10.100.1.0 0.0.0.255 area 0
 network 172.30.0.0 0.0.3.255 area 23
!
ip classless
!
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
==================================================================================
R3#sh running-config
Building configuration...

Current configuration : 1144 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
no ip domain lookup
ip domain name lab.local
!        
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.23.1.3 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 stub
 passive-interface default
 no passive-interface Serial0/0
 network 10.23.1.0 0.0.0.255 area 23
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
==================================================================================
R4#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R4#sh run
R4#sh running-config
Building configuration...

Current configuration : 1252 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!    
no ip domain lookup
ip domain name lab.local
!        
interface FastEthernet0/0
 ip address 10.100.1.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 10.45.1.4 255.255.255.0
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 area 45 stub
 passive-interface default
 no passive-interface FastEthernet0/0
 no passive-interface Serial0/0
 network 10.45.1.0 0.0.0.255 area 45
 network 10.100.1.0 0.0.0.255 area 0
!        
ip classless
!        
!        
no ip http server
no ip http secure-server
!            
control-plane
!              
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login   
!        
!        
end
===================================================================================
R5#sh running-config
Building configuration...

Current configuration : 1086 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!
!
!        
!
no ip domain lookup
ip domain name lab.local
!       
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.45.1.5 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 area 45 stub
 passive-interface default
 no passive-interface Serial0/0
 network 10.45.1.0 0.0.0.255 area 45
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
==================================================================================
R6#sh running-config
Building configuration...

Current configuration : 1268 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!      
no ip domain lookup
ip domain name lab.local
!               
interface FastEthernet0/0
 ip address 10.100.1.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 10.67.1.6 255.255.255.0
 clock rate 2000000
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 area 67 virtual-link 7.7.7.7
 passive-interface default
 no passive-interface FastEthernet0/0
 no passive-interface Serial0/0
 network 10.67.1.0 0.0.0.255 area 67
 network 10.100.1.0 0.0.0.255 area 0
!        
ip classless
!             
no ip http server
no ip http secure-server
!              
control-plane
!                
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login   
!        
!        
end
==================================================================================
R7#sh running-config
Building configuration...

Current configuration : 1182 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!      
no ip domain lookup
ip domain name lab.local
!        
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.67.1.7 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.78.1.7 255.255.255.0
 clock rate 2000000
!
router ospf 1
 router-id 7.7.7.7
 log-adjacency-changes
 area 67 virtual-link 6.6.6.6
 passive-interface default
 no passive-interface Serial0/0
 no passive-interface Serial0/1
 network 10.67.1.0 0.0.0.255 area 67
 network 10.78.1.0 0.0.0.255 area 78
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
==================================================================================
R8#sh running-config
Building configuration...

Current configuration : 1072 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R8
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
ip cef
!    
no ip domain lookup
ip domain name lab.local
!        
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.78.1.8 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!        
router ospf 1
 router-id 8.8.8.8
 log-adjacency-changes
 passive-interface default
 no passive-interface Serial0/0
 network 10.78.1.0 0.0.0.255 area 78
!
ip classless
!
no ip http server
no ip http secure-server
!
control-plane
!

line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
==================================================================================

Tuesday, October 8, 2013

OSPF Case Study

Objectives
• Plan, design, and implement the International Travel Agency network shown in the diagram and described below.
• Verify that all configurations are operational and functioning according to the guidelines.

1. Use the addressing scheme shown in the diagram.
2. Configure OSPF with the networks shown in the diagram.
3. Configure the OSPF backbone area to be on Loopback0 on HQ.
4. Configure the Frame Relay subnets as point-to-point subinterfaces, with the link between HQ and East in area 100, and the link between HQ and West in area 300.
5. Configure area 300 as an NSSA.
6. Configure the router East loopback interfaces to be in area 200. Summarize this area with the most efficient summary.
7. Redistribute the loopback network on router West into OSPF.
8. Create virtual links as necessary for full connectivity.
9. Make sure that all loopback interfaces are advertised with the correct subnet mask.

Tcl Script Verification
R1# tclsh
foreach address {
10.1.1.9
10.1.1.13
10.1.1.101
10.1.1.105
10.1.1.109
10.1.1.113
10.1.1.1
10.1.1.2
10.1.1.5
10.1.1.6
} {
ping $address }
Verified when completes lab
R1(tcl)#foreach address {
+>(tcl)#10.1.1.9
+>(tcl)#10.1.1.13
+>(tcl)#10.1.1.101
+>(tcl)#10.1.1.105
+>(tcl)#10.1.1.109
+>(tcl)#10.1.1.113
+>(tcl)#10.1.1.1
+>(tcl)#10.1.1.2
+>(tcl)#10.1.1.5
+>(tcl)#10.1.1.6
+>(tcl)#} {
+>(tcl)#ping $address }

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/20/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.101, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/22/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.105, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/13/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.109, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/12/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.113, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/36 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/15/72 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/22/60 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/17/84 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/14/28 ms
R1(tcl)#exit

====================================================
Device Configuration ::::::
R1#sh running-config
Building configuration...

Current configuration : 1488 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!no ip domain lookup
ip domain name lab.local
!        
interface Loopback1
 ip address 10.1.1.9 255.255.255.252
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
!        
interface Serial0/0.102 point-to-point
 ip address 10.1.1.1 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 102  
!
interface Serial0/0.103 point-to-point
 ip address 10.1.1.5 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 103  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 100 virtual-link 10.1.1.113
 area 300 nssa
 network 10.1.1.0 0.0.0.3 area 100
 network 10.1.1.4 0.0.0.3 area 300
 network 10.1.1.8 0.0.0.3 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
========================================================

R2#sh running-config
Building configuration...

Current configuration : 1746 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback101
 ip address 10.1.1.101 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback105
 ip address 10.1.1.105 255.255.255.252
 ip ospf network point-to-point
!
interface Loopback109
 ip address 10.1.1.109 255.255.255.252
 ip ospf network point-to-point
!        
interface Loopback113
 ip address 10.1.1.113 255.255.255.252
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
!
interface Serial0/0.201 point-to-point
 ip address 10.1.1.2 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 201  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 100 virtual-link 10.1.1.9
 area 200 range 10.1.1.96 255.255.255.224
 network 10.1.1.0 0.0.0.3 area 100
 network 10.1.1.100 0.0.0.3 area 200
 network 10.1.1.104 0.0.0.3 area 200
 network 10.1.1.108 0.0.0.3 area 200
 network 10.1.1.112 0.0.0.3 area 200
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!        
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end
======================================================
R4#sh running-config
Building configuration...

Current configuration : 1380 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback3
 ip address 10.1.1.13 255.255.255.252
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.301 point-to-point
 ip address 10.1.1.6 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 301  
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!        
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 area 300 nssa
 redistribute connected subnets
 network 10.1.1.4 0.0.0.3 area 300
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

=======================================================
FRS#sh running-config
Building configuration...

Current configuration : 1404 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
no ip domain lookup
ip domain name lab.local
!        
frame-relay switching
!          
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
 frame-relay route 103 interface Serial0/2 301
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end

=======================================================

Monday, October 7, 2013

OSPF over Frame Relay ( Point to Point , Point to Multipoint NBMA)

I hope this blog will help for easy referencing in Labbing framrelay with OSPF .when i doing first time Labbing , router uses as framerelay switch hv some mismatch configuration.
I hope this information will be informatics for CCNP Route Lab.All received are copied from
CCNP Route Lab manual . Just Only copied the most important role of this lab.

Objectives

 

  1. Configure OSPF over Frame Relay.
  2. Use non-broadcast and point-to-multipoint OSPF network types.
  3. Modify default OSPF timer
 Step 1: Configure Frame Relay and addressing on the HQ, EAST, and WEST routers.

 Step 2: Configure the Frame Relay switch

 Step 3: Configure OSPF network type NBMA.

 On EAST and WEST, change the Frame Relay interfaces to have OSPF priority 0. This priority ensures that HQ becomes the DR.(For Point to Point Type)
Configure neighbor statements on HQ pointing toward EAST and WEST.And EAST and WEST also Pointing toward to HQ .

Step 4: Change the network type to point-to-multipoint


 Step 5: Change OSPF timers.

Q : What are some disadvantages to changing the timers if they are not tuned correctly?

Ans : If timers are not tuned correctly, there are many negative side effects. Hello packets can saturate a slower link or overload a slower router. Route instability and route flapping can occur from bad timers having an adjacency come up and down. If timers are tuned to take too long, reconvergence of a network after topology changes can be slower.

Challenge: Minimal Hello Intervals

Configure the Fast Ethernet link between EAST and WEST to lower the convergence time using the ip ospf dead-interval minimal hello-multiplier multiplier command. This command sets the dead interval to 1 second. Hellos will be sent at the rate of multiplier per second. 

Use the following Tcl script to verify connectivity to all addresses in the topology.
 
HQ# tclsh
HQ(tcl)#
foreach address {
10.1.1.1
10.1.2.1
10.1.3.1
10.1.123.1
10.1.123.2
10.1.123.3
10.1.23.2
10.1.23.3
} {
ping $address }


Final Device Configuration 

 HQ#sh running-config
Building configuration...

Current configuration : 1346 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HQ
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.123.1 255.255.255.0
 encapsulation frame-relay IETF
 ip ospf network point-to-multipoint
 clock rate 2000000
 frame-relay map ip 10.1.123.1 102
 frame-relay map ip 10.1.123.2 102 broadcast
 frame-relay map ip 10.1.123.3 103 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!       
end


======================================================
EAST#sh running-config
Building configuration...

Current configuration : 1443 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EAST
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 ip ospf dead-interval minimal hello-multiplier 5
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.123.2 255.255.255.0
 encapsulation frame-relay IETF
 ip ospf network point-to-multipoint
 clock rate 64000
 frame-relay map ip 10.1.123.1 201 broadcast
 frame-relay map ip 10.1.123.2 201
 frame-relay map ip 10.1.123.3 201 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 10.1.2.0 0.0.0.255 area 0
 network 10.1.23.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login   
!
!
end

======================================================
WEST#sh running-config
Building configuration...

Current configuration : 1445 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WEST
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
no ip domain lookup
ip domain name lab.local
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 10.1.23.3 255.255.255.0
 ip ospf dead-interval minimal hello-multiplier 5
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.123.3 255.255.255.0
 encapsulation frame-relay IETF
 ip ospf network point-to-multipoint
 clock rate 2000000
 frame-relay map ip 10.1.123.1 301 broadcast
 frame-relay map ip 10.1.123.2 301 broadcast
 frame-relay map ip 10.1.123.3 301
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 10.1.3.0 0.0.0
 network 10.1.23.0 0.0.0.255 area 0
 network 10.1.123.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login   
!
!
end

=======================================================
FRS#sh running-config
Building configuration...

Current configuration : 1484 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
no ip domain lookup
ip domain name lab.local
!
frame-relay switching
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache cef
 no ip route-cache
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
 frame-relay route 103 interface Serial0/2 301
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 encapsulation frame-relay IETF
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
 no ip address
 encapsulation frame-relay IETF
 no ip route-cache cef
 no ip route-cache
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/0 103
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end 


 ========================================================